How to fix 'Connection to steemd.steemit.com timed out'

in witness-category •  11 months ago

steemd_issue.png

First of all this is not an issue, this is excepted behaviour. Yesterday (1/6/18) the Steemit Inc decommissioned obsolete steemd.steemit.com RPC node as they communicated few times before.

The new public API node api.steemit.com uses http/jsonrpc instead of RPC protocol and most popular libraries like steem-js, steem-python, radiator or dsteem are compatible out of the box.

How to fix it?

If your application reports connection timeout errors, similar to below,

WARNING:urllib3.connectionpool:Retrying (Retry(total=15, connect=None, read=None, redirect=0, status=None)) after connection broken by 'ConnectTimeoutError(<urllib3.connection.VerifiedHTTPSConnection object at 0x7f0dde1439b0>, 'Connection to steemd.steemit.com timed out. (connect timeout=60)')': /

it means your application endpoint is still set to disabled node. The fix is very easy and all what you need to do is replace the old node steemd.steemit.com by the new one api.steemit.com.

For tools built on top of steem-python you can use steempy and set new default node,

$ steempy set nodes https://api.steemit.com

or change it directly in the code,

nodes = [
    'https://api.steemit.com',
]

s = Steemd(nodes)

 
It's always good to define a few API servers and if you're looking for the list of available public API nodes please check my tool https://geo.steem.pl, or run curl geo.steem.pl in your terminal ;-)


If you think I can be a good witness, please vote for me.

Thank you!

Authors get paid when people like you upvote their post.
If you enjoyed what you read here, create your account today and start earning FREE STEEM!
Sort Order:  

when i run steempy it gives me this error

Traceback (most recent call last):
File "/usr/local/bin/steempy", line 7, in
steem.cli.legacy()
File "/usr/local/lib/python3.6/dist-packages/steem/cli.py", line 83, in legacy
version=pkg_resources.require("steem")[0].version
File "/usr/local/lib/python3.6/dist-packages/pkg_resources/init.py", line 984, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/local/lib/python3.6/dist-packages/pkg_resources/init.py", line 875, in resolve
raise VersionConflict(dist, req).with_context(dependent_req)
pkg_resources.ContextualVersionConflict: (toml 0.9.3 (/usr/local/lib/python3.6/dist-packages), Requirement.parse('toml==0.9.3.1'), {'steem'})

·

I already solved it, i changed the version requirement to 0.9.3, and it works, this post was helpfull, thanks

Thanks! That was a big help!

·

Thanks, great to hear that ;-)

Thanks for posting this.

Wondering why you imported as Steemd instead of Steam?