97 Cherokee transmission service

in automotive •  2 months ago

Well last weekend I pulled my jeep into the shop to do a transmission service. Which consisted of changing the filter and solenoids. I've been having issues with my transmission not shifting right so thought it was time for a service. So first I drained the transmission pan.52607941_10161621086965694_5464812814294056960_n.jpg After I got the pan drained and out of my way I was able to start replacing solenoids one by one and the filter. 53179275_10161621087470694_7450654268597469184_n_LI.jpg Once I got it all finished up and the transmission filled I went to fire it up and see what it did. Well when I hooked my battery back up it was dead. So after charging my battery up and replacing my alternator52853995_10161642764580694_8047721689871548416_n.jpg I discovered that my jeep still wont shift right. Next ill try replacing the TCM53588150_10161642776375694_5042433790396334080_n.jpg So Ive ordered a new Transmission Control Module (TCM) and will hope that fixes it. I'll update next weekend after part has come in and I've been able to get it installed.

Authors get paid when people like you upvote their post.
If you enjoyed what you read here, create your account today and start earning FREE STEEM!
Sort Order:  

hope it all works out for you sweetheart...

That trans fluid is looking a bit dark but it didn't look too bad on the inside.

·

Yeah i was suprised at the color but it didnt smell burnt so i was glad.

Little by little! Hang in there!

I thought of something else because you mentioned your battery was dead. This usually resets the saved shift points in the TCM so the car has to 'learn' to shift again. It will shift 'funny' until the shift points are re-learned. If your car ever goes into the 'limp home' mode usually clears shift points too. Google for 'learning transmission shift points' for info. Maybe you didn't need a new TCM. If you have been running the battery dead that could be the cause of the transmission shifting funny. If battery is removed for 30 minutes, the shift points are erased. Good luck, Chicklet.

·

What its doin is if I put it in drive it doesnt wanna go. If i drop it down in 1st manually it goes and I can shift it out that way.

·
·

Sounds like you need a transmission diagnostic from someone you can trust not to sell you a rebuilt that you don't need yet. I found a trustworthy trans shop near me by going to car talk .com. They did car repair help radio talk shows for decades, Click & Clack, noisy tappets. Here is a link to find a good shop near you https://www.cartalk.com/mechanics-files just put in your location and find a good shop from reviews. A trans shop can plug into your trans and see exactly what the problem is, replace the switch, sensor whatever and get you going. You just need to find a trustworthy local trans shop that won't cheat you. Cartalk has good repair archives online that you would like to read. Is great learning material.

·
·

Was it doing this before you changed the fluid? Are you checking fluid level, idling in NEUTRAL cause in park always shows full? I watched a complete teardown of your tranny on youtube and way too many parts for me. It is a Toyota trans and used in the Tacoma. I have rebuilt engines but never been ambitious enough to do do an automatic transmission. Nope, not doing that.

·
·
·

Yes, fluid levels were good. Was driving it then all the sudden its like it wasnt downshiftin when put in drive. I stopped at a stop sign then when i went to take off it wouldnt go. Dropped it down into 1st 2nd and it went.

·
·
·
·

Thanks for the symptom with what it was doing. I looked that up and is common on Jeep cause lots of people with a no downshift trans issue. You also need to check the TPS throttle position sensor for proper voltages with a voltmeter as this controls the tranny shifting. The TPS voltages are into the ECU not the TCU trans controller. Also found a few links you should read.
https://www.wranglerforum.com/f282/transmission-wont-downshift-help-817970.html
http://midsouthjeeps.com/forum/topic/260-automatic-transmission-wont-downshift/ this is about a plugged vent hole (plugged with mud)
https://www.jeepforum.com/forum/f310/won-t-downshift-stop-1201294/
governor pressure solenoid and sensor, under filter tray that you just did

So this is 3-4 more things to check. Lots of other people have had this problem too. good luck.

Hey greasemonkeychicklet, what a name! Have you adjusted your TV cable? Here is a video on how to do it. If not adjusted properly it can cause late or early shifting. Here is video for a jeep and hope it helps.

·

Wow I never knew the kick down cable could adjust like that! Thanks for the video hunnybadger. Ill check that out on mine too but I'm afraid its not gunna be that simple of a fix.

Make sur it is actually starting off in 1st gear wen you shift it manually. If it is starting off in second maybe a broken band, not sure. Also not sure if that trans has a governor. If I have all the details on the jeep I can check Alldata for you.